Follow

Upgrade from IE7

Some of our new features are not supported by older versions of Internet Explorer (IE). This has come as no surprise and we have always maintained from day one that users should be using a modern browser. However, if there are any users that have been using IE despite our recommendation, then now is the time to consider upgrading Internet Explorer or using another browser. Please read our article on Minimum Browser Requirements.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk